Results 1 to 3 of 3
  1. #1
    Joined
    Nov 2001
    Location
    Rome, Ga.
    Posts
    52

    This PS any good??

    I am looking to purchase this PS, it looks good and the voltage #'s look good and beefy, and as far as looks goes it matches my interior poifectly! nyuck nyuck. Damn, sorry, curly moment.

    http://www.frozencpu.com/cgi-bin/qu...age=search.html

    And if you need more info Virtual Hideout did a review of it here:
    http://www.virtual-hideout.net/revi...psu/index.shtml


    Btw: it will be replacing my antec400W R.I.P. Hope it will fit and all, do PS's have a standard as far as mounting goes??
    Last edited by rabiddog22; 03-21-2002 at 09:28 AM.
    Case- Antec SX1240 with 400W PS-
    Motherboard- Tyan Tiger MP V1.02-
    Proc's- 2X AMD 1800 XP (Non MP!)-
    Memory- 1 GIG Crucial DDR-
    (Yes! Crucial, and more coming.)
    Heatsinks- Thermaltake Volc. 6CU's-
    (NOW WITH YS_TECH 7500 RPM FANS)
    (You talkin about my Heatsinks boy?)
    Soundcard- Creative Labs Aud. Plat.-
    Video Card- Geforce3 Ti500-
    Hard Drives- 60GB 7200RPM Maxtor-
    Optical Drive- Creative Labs 52X CD-
    Cdrw Drive- New TEAC>Plextor Killer
    Op. System- Window's XP Pro-

    "Sir, that would be an insult to me, my religion, and my god, but...OK!!!"

  2. #2
    Joined
    Nov 2001
    Posts
    2,408
    Rabid, neither of those links is working . What happened to your Antec, anyway?

    Chris
    Epox 8RDA w/ 512 MB TwinMOS PC3200 (2x256MB)-=-Athlon XP 1700+ JIUHB:0310WPMW @ 2,305 (1.775v) 11.5 x 200 FSB-=-Antec ATX12V 400W PSU-=-Sapphire Radeon 9700 Pro @ 412/358-=-SB Live 5.1-=-Linksys NIC-=-Pioneer DVD-ROM drive-=-WD 'SE' 80GB-=-Chieftec Case w/ four 80 mm fans-=-WinXP Pro

    Watercooled: D-Tek White Water-=-DD Maze4 GPU-=-1972 Chevy K10 Pickup heatercore-=-2x120mm Evercool fans-=-HydorL30-=-1/2 ID Clearflex60-=-Zerex coolant

  3. #3
    Joined
    Nov 2001
    Location
    Rome, Ga.
    Posts
    52
    Darn, worked before.....GROWl.

    Lightning strike, I have a RCA dish and I thought I had grounded it properly. But alas, no. It took out my tv, my 250$ power strip and my PS. (thank god i had my rig tore apart at the time) but I did have my PS hooked up. Still can't believe it. I'm gonna miss the little guy.

    As far as the new one goes, here's the specs:
    -Aluminum construction
    -Pentium 4 supported
    -High MTBF
    -115V or 230V Input
    -Dual fan

    +3.3V 28A
    +5V 40A
    +12V 18A
    +3.3V & +5V 240W Max
    Total Output 450W Max
    , for a pic go to www.frozencpu.com and look under Ps's
    Case- Antec SX1240 with 400W PS-
    Motherboard- Tyan Tiger MP V1.02-
    Proc's- 2X AMD 1800 XP (Non MP!)-
    Memory- 1 GIG Crucial DDR-
    (Yes! Crucial, and more coming.)
    Heatsinks- Thermaltake Volc. 6CU's-
    (NOW WITH YS_TECH 7500 RPM FANS)
    (You talkin about my Heatsinks boy?)
    Soundcard- Creative Labs Aud. Plat.-
    Video Card- Geforce3 Ti500-
    Hard Drives- 60GB 7200RPM Maxtor-
    Optical Drive- Creative Labs 52X CD-
    Cdrw Drive- New TEAC>Plextor Killer
    Op. System- Window's XP Pro-

    "Sir, that would be an insult to me, my religion, and my god, but...OK!!!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •