Results 1 to 3 of 3
  1. #1
    Joined
    Jun 2002
    Posts
    2

    Unhappy The Not So Great new hard drive Odyssey

    Oh, what a journey it has been...let me start from the beginning...

    Purchased an 80GB Samsung 7200RPM hard drive, because the price was right, and my 40GB drive is cramped. Then the problems began...

    Installed the drive as slave on the same IDE channel (I believe 0) as my other drive, since 1) current cable length limitations prevented me from making it master on the other channel, and moving my DVD drive to slave 2) I don't think with the other bottlenecks in my system I'd see a massive performance gain (I was going to check the PIO mode of my DVD drive, but didn't bother because my desired config is physically impossible at the moment).

    = If you have any input on this issue, go ahead, but this isn't the problem behind this post, just the setup.

    No hassles besides not being able to achieve my desired configuration in any aspect of the physical installation. I will note that I selected "Cable select" as jumper configuration, instead of slave, though I don't see how that could be responsible for the issues I'm having.

    First problem is Windows 9X and the impossibility of keeping my DVD as D:. I am thoroughly disgusted by the OS by this point, and the many incredibly backwards "features" built in that M$ will never address, but instead release a new OS at $100 and up for you to escape the torture of their glaring sloppiness.
    My first guess as to the cause of the problem is the steps I took over and over to try to get around this until I was finally convinced it was impossible. I detail them here for reference:

    - All the partition programs I use complain about my MBR and EMBR on my main partition, which may be related to the way I installed Linux. It causes no problems other than these complaints, so I ignore it. I will say that the main drive has a primary partition and 4 linux partitions (logical on extended)
    - All attempts are to create a first partition for swapfile usage, about 2 GB in size (a bit bigger, so I don't think my problem is that it is using FAT16...you'll see why this is a concern later), and a second partition for the rest of the disk. ...FAT32 of course. Also, all attempts are for 2 logical drives on an extended partition.

    - I first used fdisk in safe mode to create two partitions. All went through with no problems, except my DVD moved letters.
    - I tried Ranish Partition Manager 2.42 in safe mode. Easy to use interface, but booting after use caused the computer to hang. I had to disable, reboot, then reenable to work on the drive partitions again. I stopped using this altogether.

    Now, fdisk works best...with the drives unformated, I have a "D" and "E" exactly where they are supposed to. When my DVD didn't have a letter specified in Device Manager, it ended up being assigned the next available letter. I now have it set to a new letter later in the alphabet so I don't have to be distracted by it anymore. The main problem occurs when I format them, but I'll get to that after I detail the steps I tried initially to get my DVD to be "D"

    - I deleted the drive partitions on the new drive, and picked "D-F" in Device Manager for the DVD (I wanted the HD to be at "G"). Didn't work, ended up being ignored and ghosted out when viewed upon boot with partitions created.
    - I did the same again, but picked just "D". Same effect.
    - I downloaded and tried letter assigner 1.1.2. In the problem instance I describe for when the new partitions have been formatted and I've rebooted, it gave me an error about getting drive info and failed to write any changes even after I got letters reassigned to devices.
    - I did the same with letter assigner after using fdisk, rebooting, and formatting...rebooted again, same problem as if I'd never used letter assigner.
    - I learned about registry entries at HKLM...Enum/ESDI and Enum/SCSI. I tried changing the UserDriveLetter and CurrentDriveLetter assignments for the ESDI entry for my new drive to GG and GH in that order. No go, same problems.

    OK, that's what I tried before I gave up on having my DVD remain "D". Now to what I'm trying now:

    - Using fdisk, the only way to get an expected result, in both safe mode and standard boot (no difference in results noted), I create the 2 partitions as described. I then reboot and have "D" and "E" as RAW drives.
    - After formatting the drives, and opening "My Computer" again, I have a formatted "D" and "E" with the proper names, giving all indications that they will work properly, except that when looking at the System cpl under Performance tab I have "Drive D is using MS-DOS compatibility mode file system". This is the focus of my efforts, and what I consider the cause of the problem that occurs next...
    - If I simply rebooted from the apparently successful format, I ended up with an odd and rather unstable looking drive list: "D" as a RAW unformatted partition of the right size, "E" as a properly formatted of the right size, "F" as a formatted partition of the right size (for "D").

    This led to my use of what I learned in my earlier quest to get my DVD to stay at "D":

    - I deleted the partitions.
    - I deleted the Enum/ESDI entry for the new hard drive (I had long since verified that the Enum/SCSI entry for the DVD has proper letter assignments).
    - I deleted the Enum/SCSI entries for my compact flash (edisk) and camera (sony) readers, after uninstalling the compact flash reader (I can't locate an entry for the Sony camera reader...I think it was a "plug and play" install for that driver). They had used "E" and that seems a possible conflict with my current config.
    - I deleted the Software/Microsoft/Windows/Explorer/MountPoint entries for all the various letters that were created in my quest up until this point (i.e., all except C and the new letter for my DVD).
    - I created the partitions with fdisk again.
    - I reboot

    Here is where it changed a little. After I format "D" and "E" and reboot, I don't get "D" RAW, "E" formatted, and "F" formatted like "D" is supposed to be, I just get "D" RAW and "E" formatted. I still get the same "Drive D is using MS-DOS compatibility mode file system" before and after trying to format it (yes, I looked at the "What is?" for this, but it bolds a text phrase to look up in help, but a search for "compatibility" fails...I'll keep looking)
    That's the extent of my progress for today.

    Now, I know a lot of you have done lots of upgrades, so what I'm hoping is that you can either point out something obviously wrong and simple (or maybe not so simple) to fix, give me some clues on how to understand the message I'm getting about D and how it might relate to my problem with "D" not remaining formatted, or give me a pointer or starting point for further research into this problem.

    Any takers?

    I do hope the information presented is clear enough. Also, let me include system specs for reference.

    Epox 8KTA+, 256MB PC133, AMD TBird 1.3@1.377/106FSB
    Windows ME, all latest patches applied
    ATI AIW Radeon 8500 128MB, 9031 drivers
    Typical systray Sygate PF, Cacheman 5.11 (disabled for several attempts), Folding@Home,Enternet 300,VShield (latest patch) with no System Scan (disabled for several attempts).

  2. #2
    Joined
    Jun 2002
    Posts
    2

    ...a trail is discovered...

    Looked under HKLM...Services/VxD/IOS/registry (all my registry paths have more to them, but I just mention enough to be distinctive) for a "NoIDE" entry...not one there (only "Start"=00 and "StaticVxD"="*IOS"noide"), and searched registry for "noide" and"bad_ide"...nothing found. Also searched for "no ide", "badide", and "bad ide" to check further.
    This didn't help, but atleast taught me what isn't wrong.

    Also, I took a peek at \Windows\IOS.LOG and found this:

    Error issuing int 25h: unit 03, error 0000BABE
    Unit number 03 going through real mode drivers.

    Driver Name:
    Block Driver controlling 05 unit(s)
    Driver Info:
    Driver Address:
    IOSYS INT 13:
    INT 13 Hook:
    INT 4B Hook:
    INT 4F Hook:
    Config.sys line number:

    Driver Name:
    Character Driver
    Driver Info:
    Driver Address:
    INT 13 Hook:
    Config.sys line number:
    Hardware interrupt hook map:

    Driver Name:
    Character Driver
    Driver Info:
    Driver Address:
    Config.sys line number:

    Autoexec Date/Time Stamp:
    Well, this looks like my exact problem...but what does it mean exactly and how do I fix it? No yellow or red for my hard drive or ide controller entries in device manager.

    EDIT: I have done a virus scan with Mcafee VScan, the latest update, and it found nothing.
    Last edited by demalion; 06-07-2002 at 05:55 AM.

  3. #3
    Joined
    Mar 2002
    Location
    Newfoundland, Canada
    Posts
    226
    Did you try using the hard drive in another computer? Could be that the hard drive is broken

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •