Results 1 to 4 of 4
  1. #1
    Guest

    Question

    I have a K7M with audio onboard and am trying to get it to work under Linux (I have RedHat 6.2).
    I tried to configure audio with sndconfig, but it did not work. The VIA chipset is auto-detected, but auto-configuring does not set the right parameters (I think auto-configuring is thought for ISAPnP cards only). When eventually sndconfig tests his settings, the system hangs and the only thing to do is rebooting... (maybe a false interrupt request???). What is worse, sndconfig saves his settings before testing them, so at the next Linux startup the system will hang when starting the audio module, and there is no way to get into Linux to fix the problem! RedHat 6.2 has an "interactive startup" feature that allows the user to confirm every step in the startup process, but it is not possible to start it before the sound module is loaded...

    I am thinking of adding some parameter lines in the /etc/conf.modules file, but I have no idea of what I should type...
    In the Win98 control panel I have found the IRQ channel and 3 I/O addresses that the VIA chipset uses, but nothing about DMA channels.
    The problem is, I do not know how to tell Linux to use these settings.

    Does anyone have the information I need?


    Thank you

  2. #2
    Guest

    Post

    you might want to try moving some of the cards (put them in different PCI slots)
    because the K7M dedicates certain slots to share IRQ's with other slots...

    I believe it goes like this..

    Slot 1 - Shares with slot 5 and the AGP
    Slot 2 - IS NOT SHARED
    Slot 3 - Shares with Onbard Audio
    Slot 4 - Shares with USB
    Slot 5 - Obviously shared with slot 1

    ... and keep in mind that if there are ISA cards installed the motherboard will automatically assign those IRQs before it assigns the PCI.

    I do not use Linux so this is the best thoughts I have on the subject.

    Hope this helps.

  3. #3
    Guest

    Post

    You may find your answer/patch here:
    http://gtf.org/garzik/drivers/via82cxxx/

    Many people are having the same problem and have posted the same question

  4. #4
    Guest

    Post

    I belive most Linux distros need to have an entry in /etc/modules.conf to auto-load modules. If you get into that file and comment out any sound related stuff, it should keep the sound drivers from starting. If I put my SBLive! module line in there it will auto-start the module when something trys to access the card. I use SuSE and that is the way it works, so I am not sure if Red Hat does the same. That should at least get you back up and running.

    jImbEam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •