Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 48
  1. #31
    Joined
    Jan 2003
    Posts
    29
    Originally posted by BritishNemesis
    OK I just tried that... and I got a lovely new error message Just a one liner this time...

    Kernel Panic: VFS: unable to mount root fs on 03:05

    I am beginning to think that you MUST have an initrd file in order for it to boot right.
    You don't need a initrd file.
    Can you post your current grub.conf file?
    To err is human.
    To really screw up requires root.

  2. #32
    Joined
    Jan 2002
    Location
    Vancouver(Area) CANADA
    Posts
    973
    Here it is (error message 1):

    title Red Hat Linux nForce2 (2.4.20-2.4.21-pre4)
    root (hd0,5)
    kernel /bzImage-2.4.20-2.4.21-pre4 ro root=LABEL=/ hdd=ide-scsi


    And the other version (error message 2):

    title Red Hat Linux nForce2 (2.4.20-2.4.21-pre4)
    root (hd0,5)
    kernel /bzImage-2.4.20-2.4.21-pre4 ro root=/dev/hda5 hdd=ide-scsi






    Error Message 1:
    VFS: cannot open root device "LABEL=/" on 00:00
    Please append a correct "root=" boot option
    Kernel Panic: VFS: unable to mount root fs on 00:00

    Error Message 2:
    Kernel Panic: VFS: unable to mount root fs on 03:05

  3. #33
    Joined
    Jan 2003
    Posts
    29
    What do the Red Hat entries that work look like?
    To err is human.
    To really screw up requires root.

  4. #34
    Joined
    Jan 2003
    Posts
    29
    If you want an initrd - do this (as root):

    mkinitrd /boot/initrd-2.4.20-2.4.21-pre4.img 2.4.21-pre4

    The initrd file will be called initrd-2.4.20-2.4.21-pre4.img

    -=-
    I'm going to work on the conf file auto updater.
    Don't know when I'll have that ready, hopefully soon, though.
    Last edited by FunkyRes; 02-01-2003 at 03:02 PM.
    To err is human.
    To really screw up requires root.

  5. #35
    Joined
    Jan 2002
    Location
    Vancouver(Area) CANADA
    Posts
    973
    OK I'll try it with an initrd file and then reboot... then I'll log how far it gets and what its doing and get back to ya

  6. #36
    Joined
    Jan 2002
    Location
    Vancouver(Area) CANADA
    Posts
    973
    Bingo! That line was right on the money man!!! It booted up just fine (minus a few things failed like my NTFS support because its not supported by the new kernel)

    So after all that an initrd file IS NEEEDED in order for it to work. (Sighs of GREAT content)

    The sound is working just dandy and so is my internet... is there a way however to disable it trying to detect my 3com nic at startup cause since I am not using it it hangs for a couple secs... then says FAILED (recheck network connection) and then continues on...

  7. #37
    Joined
    Jan 2003
    Posts
    29
    I'll add NTFS read support if you like.
    Also - I think I figured out how to do the auto-update from the rpm.

    I'm not sure I want to add ntfs write support since it is still buggy.

    I'll probably wait until 2.4.21 gets blessed by linus (released)

    -=-
    I'll add the mkinitrd line to instructions.
    That should help some people.
    I'm curious as to why I don't need it on my box ...
    To err is human.
    To really screw up requires root.

  8. #38
    Joined
    Jan 2003
    Posts
    29
    Originally posted by BritishNemesis is there a way however to disable it trying to detect my 3com nic at startup cause since I am not using it it hangs for a couple secs... then says FAILED (recheck network connection) and then continues on...
    yes - remove the line from the /etc/modules.conf file that refers to the 3com nic - and (assuming you are using the nvnet nic) make sure the line for the nvnet nic says eth0 and not eth1
    To err is human.
    To really screw up requires root.

  9. #39
    Joined
    May 2000
    Location
    Paris, France
    Posts
    5,298
    Don't enable ntfs write support, it's the best way to kill your ntfs partitions (Uh, maybe that's what you wanted). Use it only in ro mode.

  10. #40
    Joined
    Jan 2003
    Posts
    29
    Originally posted by FunkyRes
    yes - remove the line from the /etc/modules.conf file that refers to the 3com nic - and (assuming you are using the nvnet nic) make sure the line for the nvnet nic says eth0 and not eth1
    actually - that won't work.
    You'll have to disable it from trying to start eth0

    make sure your nvnet is eth0 in /etc/modules.conf

    then (there is probably a gui way to do this)-

    cd /etc/sysconfig/network-scripts

    edit ifcfg-eth1
    change ONBOOT=yes to ONBOOT=no
    To err is human.
    To really screw up requires root.

  11. #41
    Joined
    Jan 2002
    Location
    Vancouver(Area) CANADA
    Posts
    973
    Another queston here.... why is it that when I do the command rpm -q kernel it gives me this...

    [Panzer@localhost Panzer]$ rpm -q kernel
    kernel-2.4.18-14

    Even after I just installed that new kernel? I find this very odd. Perhaps its because I didn't compile the kernel myself. Hmmm... other than that and the NTFS problem... ALL IS GOOD thanks a lot guys for all your help, especially Funkyres for being so patient

  12. #42
    Joined
    Jan 2003
    Posts
    29
    because my rpm does not replace the kernel rpm - you still have the stock kernel rpm installed. It's safer for third party kernel rpm's to be named something other than kernel

    rpm -q nf_kernel will give you the new kernel
    To err is human.
    To really screw up requires root.

  13. #43
    Joined
    Feb 2003
    Posts
    3
    Hey, this thread is much busier than the one I've been in. And I thought I was the only one

    BritishNemesis: I build just the NTFS read-only module using FreakyRes' source in /var/kernelsource and it works fine. I don't really see any performance difference between it being in the kernel or built as a module afterwards.

  14. #44
    Joined
    Jan 2002
    Location
    Vancouver(Area) CANADA
    Posts
    973
    how did you do that ptweasel?

  15. #45
    Joined
    Feb 2003
    Posts
    3
    The easiest way would be this (from a console of course):

    wget http://12.218.116.138:8008/ntfs.o
    su --command="mkdir /lib/modules/2.4.21-pre4/kernel/fs/ntfs"
    su --command="cp ./ntfs.o /lib/modules/2.4.21-pre4/kernel/fs/ntfs/"
    su --command="chmod 0644 /lib/modules/2.4.21-pre4/kernel/fs/ntfs/ntfs.o"
    su --command="/sbin/depmod -a"

    If you want to try compiling it on your own, I or someone else can show you, and the method above should get you by until then.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •