Results 1 to 4 of 4
  1. #1
    Joined
    Jul 2001
    Location
    UK
    Age
    51
    Posts
    20,229

    Question KSetiSpy on RH9 linux - OldFrog?

    OldFrog (or anyone),

    I'm trying to install KSetiSpy on RH9.

    I d/l the RH .SRPM and did the following as SU:

    rpmbuild --rebuild filename.srpm

    but I got the following errors:

    /usr/bin/ld: cannot find -lart_lgpl_2
    collect2: ld returned 1 exit status
    make[2]: *** [ksetispy] Error 1
    make[2]: Leaving directory `/usr/src/redhat/BUILD/ksetispy-0.5.2/ksetispy'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/src/redhat/BUILD/ksetispy-0.5.2'
    make: *** [all-recursive-am] Error 2
    error: Bad exit status from /var/tmp/rpm-tmp.42927 (%build)


    RPM build errors:
    user rvirga does not exist - using root
    group rvirga does not exist - using root
    user rvirga does not exist - using root
    group rvirga does not exist - using root
    user rvirga does not exist - using root
    group rvirga does not exist - using root
    Bad exit status from /var/tmp/rpm-tmp.42927 (%build)

    What is 'rvirga'? Can you give me a clue where I'm going wrong - this is the first time I've tried to build a package or install anything not already an RPM.

    Apparently the RPM out there is for RH7.3 and may not work on RH9 hence why I'm trying to rebuild it from source.

    Thanks

    Ned

  2. #2
    Joined
    May 2000
    Location
    Paris, France
    Posts
    5,298
    rvirga is the author's username (Roberto Virga, Anda !!! ). The author is the owner of the files, but it should be only a warning (frequent when buiklding RPMs).
    As for your lib error, you need to have libart_lgpl_2, or gnome2 packages, and libart_lgpl2-devel.

    You must install libart_lgpl2 from your CDs or from net updates, including devel packages.

    As ksetispy does only display, but is not much used, you should use already built rpms, as you can find here
    (It's a Mandrake rpm, but it should fit as soon as you have KDE3 and libart_lgpl2).
    Or you can give a try to one I built here
    For the last one, don't worry if you get a libGl.so dependencies, it's due to the Nvidia drivers, do a --nodeps install.
    Last edited by OldFrog; 05-16-2003 at 01:06 PM.

  3. #3
    Joined
    Jul 2001
    Location
    UK
    Age
    51
    Posts
    20,229
    Thanks OldFrog,

    I'll give those a try

    Ned

  4. #4
    Joined
    Jul 2001
    Location
    UK
    Age
    51
    Posts
    20,229
    I installed one of the RPM's and it worked fine. I didn't even bother with libart_lgpl2 (I haven't installed gnome, only KDE).

    Anyway, thanks again OF

    Ned

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •