Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Unhappy no Internet, no server connect?

    Got into work this morning around 7am and had no Internet or no server connection; although, after trying a new ethernet cable, checking bios settings, rebooting the server twice and uninstalling the network device, I constantly get the disconnected thing in the task bar (didn't come up as readily before). We don't have an IT guy here, so I'm on my own. Seems everyone else can connect except me. Of course, now Windows tells me I need to activate again because I change my hardware settings significantly (WTF!), when all I did was uninstall and reinstall the ON-BOARD lan drivers. It's not like it's anything new or anything.

    Funny thing is Friday we had a power outage at work at the end of the day and I lost my Internet connection. I thought it was the server, so I turned off my computer for the weekend and rebooted the server as it was time to leave anyway. Well, then (top of post). I'm now thinking of trying to restore a DriveImage of the C: drive imaged near the end of the day Friday and see if that works. If it doesn't, then it looks like the on-board LAN might be fried on the motherboard. Any other ideas? Here are my work computer specs:

    XP Pro
    P4 2.0 Celeron
    ECS P4VMM2 MB
    512MB PC2100 DDR RAM
    S3 SavageProDDR on-board video (32MB)
    On-board sound (VIA)
    On-board LAN (VIA RhineII Fast Ethernet Adapter)
    two 40GB HDs (2 partitions each, everything imaged on 2nd HD)
    52X Samsung CD-ROM
    52X Lite-On CD burner


    .............I'm trying the DriveImage thing now..............(crosses fingers and toes)..............

    ............well, that didn't work. Any other ideas?

    Maybe I should have posted this in Tech Talk, but right now I'm disabling the Ethernet (on-board) in the Bios and installing a standard 10/100 ethernet card in a PCI slot and seeing if that works.
    Last edited by SkaarjMaster; 10-03-2005 at 10:45 AM.

  2. #2
    Joined
    Nov 2001
    Location
    E n g l a n d
    Posts
    10,978

    Re: no Internet, no server connect?

    Can you ping the server from your PC? Or visa-versa?

  3. #3
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Thumbs up Re: no Internet, no server connect?

    Separate ethernet card worked!

    I'm not looking back and don't really care if the LAN chip is fried or not. I'm connected and that's all I need to know at this point.

  4. #4
    Joined
    Nov 2001
    Location
    E n g l a n d
    Posts
    10,978

    Re: no Internet, no server connect?

    Good, well that's the main thing.

  5. #5
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Re: no Internet, no server connect?

    Just for the record, I could not ping the server from my computer and I doubt vice versa either. It works now, minor crisis averted, couple hours I'll never see again.

  6. #6
    Joined
    Dec 2000
    Posts
    5,051

    Re: no Internet, no server connect?

    Did you try doing a netsh reset before trying the new NIC?

  7. #7
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Thumbs up Re: no Internet, no server connect?

    No, I never knew that command line or any of the TCP/IP tools with XP were available. I'll make sure to try some of those things next time. Thanks for the info.

  8. #8
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Question Re: no Internet, no server connect?

    Well, now a co-worker with the same computer tried to set up a 56K modem to contact a modem somewhere else and screwed up his ethernet connection to the server somehow. Even after doing a DriveImage of the C: drive, he still could not get on the Internet, get e-mail in Outlook 2003 or find a data drive on the server. I guess I'll try the pinging thing and netsh reset and see what happens tomorrow morning. Any other ideas?

  9. #9
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Question Re: no Internet, no server connect?

    OK, I deleted all his network connections except the main one (LAN) and tried to get it to connect this morning with no luck. I also made sure his settings were the same as someone else in the office with same computer and still using the on-board LAN. Here's what I tried so far:

    1. Network Diagnostics
    Results
    - IE localhost not configured
    - network adapter passed
    - DHCP server: 255.255.255.255 invalid IP address
    - 169.254.12.222 passed

    Looks like it's reverting to Automatic Private IP Addressing (APIPA), which doesn't help us connecting through a server. I did try manual configuration (disabling auto and typing in the alternate IP adress, etc.) and this didn't work either. Also, shouldn't the default DHCP server be 255.255.255.0 and not 255.255.255.255?

    I did the same Network Diagnostics on my computer and the Internet localhost passed and both network adapters passed. Seems my on-board LAN might still be working even though I'm still connected through the ethernet card, but enough about me.

    2. IPConfig Tool
    Results
    - returned 169.254.12.222 as the IP address and subnet mask of 255.255.0.0 (but this worked on my computer)

    As above, it's reverting to APIPA.

    3. Ping Tool
    Results (I know this is redundant, but I tried it anyway)
    - destination IP for server was unreachable (worked on my computer)

    Besides making sure the settings are the same as the one of the other on-board LAN computers and rebooting the server (done both of these and verified multiple times), I'm not really sure what else to try. I've gone through the Diagnostics and Methods 1 and 2 from the MS article "How to troubleshoot TCI/IP connectivity with Windows XP" and the only thing I can come up with now is that his on-board LAN is fried somehow and he needs an ethernet card. Any other ideas?

  10. #10
    Joined
    Dec 2000
    Posts
    5,051

    Re: no Internet, no server connect?

    shouldn't the default DHCP server be 255.255.255.0 and not 255.255.255.255?
    NO, those are subnet masks.

    The DHCP server ip address should match the windows server if its running the DHCP service or the router. ( When the router is serving as a DHCP server.)

    I did the same Network Diagnostics on my computer and the Internet localhost passed and both network adapters passed.
    All this means is the network adapters are working from your computers point of view and the networking stack at the local level is working.

    Make sure to disable any firewalls on the computer and do a repair connection.

    Btw, 169 address is reserved by Windows for autoconfiguration when no DHCP server is available.

    Its not useable for LAN usage.

    Check to see what subnet and range are being used by the DHCP server.

    Also make sure he didn't install any dialup software, most of these damn things add a virtual adapter that messes up other network connections. ( For example, AOL software.)

  11. #11
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Re: no Internet, no server connect?

    "Also make sure he didn't install any dialup software, most of these damn things add a virtual adapter that messes up other network connections. ( For example, AOL software.)"

    I've come to find out, this is what happened. As stated in my post before the above long one, he installed some software for a 56K modem as well as the modem and I guess both adapters had APIPA enabled and things went bad. I also tried disabling APIPA in the registry and that didn't work either. The server subnet mask and those other settings I already tried with a manually set alternate connection and that didn't work either.

    ..........my co-worker just switched out to an ethernet card like I did and it's working for server data access and Internet. We just need to get his e-mail working now. It would be nice to know WTF happened though and if the on-board LAN problem in his and my computer are fixable or not.

  12. #12
    Joined
    Dec 2000
    Posts
    5,051

    Re: no Internet, no server connect?

    Have you tried uninstalling the NIC drivers, uninstall any 3rd party networking apps, reboot and then do a netsh int ip reset?

  13. #13
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Re: no Internet, no server connect?

    yep, did all that as well.

    I'm guessing it's some sort of bios issue with the MB and on-board LAN.

    ..............and his problems keep coming............now Outlook 2003 won't let him install Spambayes and, apparently, the number of times he's had to activate windows has expired.
    Last edited by SkaarjMaster; 10-21-2005 at 10:09 AM.

  14. #14
    Joined
    Dec 2000
    Posts
    5,051

    Re: no Internet, no server connect?

    Outlook 2003 has its own issues, mostly its security features. ( Also need to make sure any firewalls are set to allow outlook to go through as its sensitive to timeouts.)

    The activate windows message means he'd need to phone MS to activate XP again.

  15. #15
    Joined
    Mar 2002
    Location
    Sarasota, FL
    Age
    55
    Posts
    2,495

    Re: no Internet, no server connect?

    He phoned M$ and he was given a new code that generated another code or something like that and he had no problems. Apparently, he had his mail open on another computer and forgot, so his mail in Outlook 2003 works now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •