Page 1 of 6 12345 ... LastLast
Results 1 to 15 of 81
  1. #1
    Joined
    Mar 2004
    Posts
    318

    ati drivers bad install need help plz.

    fist attempt fail I need some help on commands so I can uninstall drivers also nvidia drivers are still showing in the system too so i must have don't it wrong too.But the ati control panel is there so part of the drivers must be install and could be in the wrong place.But the ati control panel is showing as using pci slot now that's way wrong.I''m sorry to bother so much But i really like to get my ati running.The only test i'v done is glxgears and it gives error for glx.
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  2. #2
    Joined
    Nov 2001
    Location
    I've moved.....I'm over here now.
    Age
    61
    Posts
    7,290

    Re: ati drivers bad install need help plz.

    Did you uncomment the DRI section and Load DRI line in xorg.conf? Did you change the Driver nvidia line back to driver vesa? And technically, an AGP slot is a PCI slot, so don't initially worry about this part.

  3. #3
    Joined
    Mar 2004
    Posts
    318

    Re: ati drivers bad install need help plz.

    when i put the ati card and booted it toke me to setup of the card did the config and i got to boot up.Install the drivers but the km file would say no path to source blalala so i use yast to install it and that way it work.Now since then I update the kernel to see if i can install again was that a good idea or a bad one.
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  4. #4
    Joined
    Nov 2001
    Location
    I've moved.....I'm over here now.
    Age
    61
    Posts
    7,290

    Re: ati drivers bad install need help plz.

    Quote Originally Posted by elvin
    when i put the ati card and booted it toke me to setup of the card did the config and i got to boot up.Install the drivers but the km file would say no path to source blalala so i use yast to install it and that way it work.Now since then I update the kernel to see if i can install again was that a good idea or a bad one.
    If the ATI drivers work the way the nvidia drivers do, every time you update the kernel, you have to re-install the driver.

  5. #5
    Joined
    Mar 2004
    Posts
    318

    Re: ati drivers bad install need help plz.

    ok I try again and the same problem shows up can't find path on the km fglrx part I'm wondering how can it be could it be that the instruction are wrong or not clear the clear part which might be confusing are they saying before you install the km part are they telling you then to install the kernel source if that is the case then I had it install already as per instruction then do I have to install it again to continue and finish it.That's where i'm stuck at again.If what i'm thinking is right then how i go about that if it was install and use once.
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  6. #6
    Joined
    Oct 2001
    Location
    Southern Ontario
    Age
    45
    Posts
    13,194

    Re: ati drivers bad install need help plz.

    If you've already installed the kernel source files once, you do not need to add them again. What distro are you using? You may have to install fglrx prior to installing the ATI drivers.

  7. #7
    Joined
    Nov 2001
    Location
    I've moved.....I'm over here now.
    Age
    61
    Posts
    7,290

    Re: ati drivers bad install need help plz.

    Quote Originally Posted by Spankin Partier
    If you've already installed the kernel source files once, you do not need to add them again. What distro are you using? You may have to install fglrx prior to installing the ATI drivers.
    Unless he upgraded the kernel. But if he used yum or apt, I would think it should upgrade the source at the same time.

    Elvin,

    I'll have a look at ATI's instructions when I get to work a little later this morning and see if anything glaring stands out. ATM, I don't have a Linux box w/ an ATI card to practice on, but I'll see what I can do.

  8. #8
    Joined
    Mar 2004
    Posts
    318

    Re: ati drivers bad install need help plz.

    Thx alot for the help I try but something has to be install wrong cause every time I try them I get stuck at the same spot.Also found out yesterday looking all over where that fglrx folder was at found it but way off.So that's as far I can figure out why all the trouble.
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  9. #9
    Joined
    Mar 2004
    Posts
    318

    Re: ati drivers bad install need help plz.

    spankin thx for trying to help.i'm useing suse 9.2 64 on a intel box shows i586 installed.
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  10. #10
    Joined
    Mar 2004
    Posts
    318

    Re: ati drivers bad install need help plz.

    I'm downloading the drivers that suse says was package for this dist.and also i'm following there installing instruction it's a help file u download where the drivers are at.
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  11. #11
    Joined
    Nov 2001
    Location
    I've moved.....I'm over here now.
    Age
    61
    Posts
    7,290

    Re: ati drivers bad install need help plz.

    Quote Originally Posted by elvin
    I'm downloading the drivers that suse says was package for this dist.and also i'm following there installing instruction it's a help file u download where the drivers are at.
    I forgot you were using Suse. Let us know how it goes. I do have some space on a test machine, that also happens to have an ATI 9800np, at home that I could install Suse 9.2 on if need be. It's just the 32 bit version, but that sounds like what you have installed anyway.

  12. #12
    Joined
    Mar 2004
    Posts
    318

    Re: ati drivers bad install need help plz.

    Ok after having some time to figure out how to install the kernel source again.I got out of xwindow and follow the instruction all again and it install.I went in like it said to the config file and look to see if dri is there and it is and fglrx is in the are for the ati card.Now I just wanted to check if i got it setup and did a check with glxgears and i got this error.

    lib: extension "GLX" missing on display ":0.0".
    glxgears: Error: couldn't get an RGB, Double-buffered visual.
    linux:~ # glxinfo
    name of display: :0.0
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  13. #13
    Joined
    Nov 2001
    Location
    I've moved.....I'm over here now.
    Age
    61
    Posts
    7,290

    Re: ati drivers bad install need help plz.

    Is the line
    Code:
    Load "glx"
    present in /etc/X11/xorg.conf?

  14. #14
    Joined
    Mar 2004
    Posts
    318

    Re: ati drivers bad install need help plz.

    yes load glx is there.
    . GA-EP45 DS3L 2GIG CORSAIR HITACHI 320 EVGA 260 216 896.

  15. #15
    Joined
    Nov 2001
    Location
    I've moved.....I'm over here now.
    Age
    61
    Posts
    7,290

    Re: ati drivers bad install need help plz.

    I am out of ideas ATM. I thought I had a copy of Suse 9.2 here at the house, but I guess it's at work. I'll retrieve it tomorrow and see what I can do. Maybe some of the Linux gurus here can solve your problem before then. Let us know if you make any progress before then.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •