Results 1 to 8 of 8
  1. #1
    Joined
    Jun 2004
    Posts
    1,765

    Questions for Logitech MX 700 Owners / Past Owners

    I had a question for anyone who uses/ had owned an MX700 Logitech mouse. I have had mine for about Ĺ a year now and have noticed it is increasingly hard to get it to charge, I find that if I like my fingers and touch my fingers to the charging plates on the bottom is one of the only ways I can get the mouse to detect the charger and in turn charge. Also there is a white ring were the rubber peace in the charger would sit on the mouse that the paint seems to have rubbed off, and 3edly the Logitech jewel seems to be coming out, the edged are starting to look right and ridged and is semi lopsided. I am very carefull with my equipment and have never mishandled this mouse before, but I do use it for hours every day, has anyone else had these issues? I still have a bestbuy replacement plan on the set somewhere if I can find it. The mouse also seems slugish latly in games but im not sure if this is an issue or just nothing at all.

  2. #2
    Joined
    Jan 2003
    Location
    Iowa, USA
    Posts
    329

    Re: Questions for Logitech MX 700 Owners / Past Owners

    I've had my MX700 since January of '04 and have not had any problems other than the paint starting to wear off of the Logitech logo. I use my computer almost all day and the mouse is used a lot. I'd try to clean the electrical contacts off, it sounds like a thin layer of dirt has built up on it. You may not be able to see it, but you will be able to tell once you get it off. I'd suggest using a cotton swab dipped in a mixture of 50% rubbing alchohol and 50% distilled water. Rub the contacts a bit then let it dry. This has never happened to me for this mouse, but I've fixed an NES and some old ISA cards this way.

  3. #3
    Joined
    Jan 2005
    Location
    MI
    Posts
    143

    Re: Questions for Logitech MX 700 Owners / Past Owners

    I've had this mouse since January now and mine works great! I've heard that some people have a hard time getting it to sit in the craddle and charge on the first try but I haven't had any problems with that. The only thing that I notice is that the longer I own it the longer the battery stays charged, which is a good thing... The alcohol on a cotton swab is a great idea, I always do this to any kind of contacts like this with any kind of electronic equipment that I own. Those contacts collect dust just like your desk or keyboard does, but it never gets wiped off. Good luck!
    --
    A64 3200+ Winchester (250*10=2500 MHz)
    MSI Neo4 Platinum Ultra
    2X 512 Corsair PC3200 XMS (2.5-3-3-8)
    MSI 6600GT (363/563 Core, 1130 Memory)
    2X 36.7 GB Raptors in RAID
    250 GB SATA WD
    Antec 480 NeoPower
    Samsung DVD-RW Drive
    Sony CD-RW Drive
    CoolerMaster Praetorian (Black)
    3DMark05 4024

  4. #4
    Joined
    Jun 2001
    Location
    Maryland
    Age
    40
    Posts
    1,366

    Re: Questions for Logitech MX 700 Owners / Past Owners

    had mine for about a year and half and no such problems...
    MOLE!!!

  5. #5
    Joined
    Jun 2004
    Posts
    1,765

    Re: Questions for Logitech MX 700 Owners / Past Owners

    Here is a photo (crappy cammera), and like i said i donít miss-treat it (like slamming it down or such).



    You can kinda see the jewel is slanted and the mark on the mouse.

  6. #6
    Joined
    Nov 2002
    Location
    New York, USA
    Age
    39
    Posts
    1,349

    Re: Questions for Logitech MX 700 Owners / Past Owners

    Had mine since Sept. '03. The only problem I've had is the charge issue, but it's fixed by just taking the mouse out of the cradle and dropping it back in. The paint on the thumb button for going BACK in the browser has worn off, so have the quick scroll buttons. Otherwise, mine still works VERY well and the batteries hold a charge for 5 days or so, though I only use it about 5 or 6 hours a day during the week.
    Coolermaster Cosmos 1000 700 watt Thermaltake modular PSU
    Asus Crosshair III Formula
    Phenom II X4 955 BE
    4 GB OCZ BE
    EVGA GeForce GTX260 Core 216 896 MB
    WD 1600JB (7200 RPM, 160 GB, 8 MB cache), external drive now
    Samsung DVD burner
    WD1000FALS 1 TB

  7. #7
    Joined
    Feb 2003
    Location
    PA
    Posts
    14,238

    Re: Questions for Logitech MX 700 Owners / Past Owners

    i have the same problem as you.

    Just get a pencil, and erase the charger electrodes, and the ones on the mouse, and it will start working.

    Im too lazy to do this, so everytime i put it in the charger, i just wiggle it around, and press down on it, and it usually works.

    "same here, it'll be a sad day should amdmb ever totally dissapear, i don't care too much for these "pc's" or their "perspectives" i just like my amdmb's." - SuBX3r0

  8. #8
    Joined
    Apr 2004
    Location
    Pullman, WA
    Age
    34
    Posts
    155

    Re: Questions for Logitech MX 700 Owners / Past Owners

    Had mine for about 2 years and I really enjoy having the wireless. No problems like you describe
    and yet I beat the living F*@# out of mine... "HEADSHOT!! WTF YOU PEICE OF..." Yea...
    Heatware
    EbayFeedback under snowxracer85
    PM me for more info OR
    snowxracer85@hotmail.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •