Results 1 to 5 of 5
  1. #1
    Joined
    Nov 2004
    Posts
    205

    "emerge" function missing?

    Hey all.

    So, I'm trying to get world of warcraft installed on my computer, which is running PCLinuxOS (newest version), and everything's going well enough, but I'm also trying to set up this "portage" thing.

    I really have no idea what it is, but the WoW How-to has recommended setting it up. Problem is, when following http://gentoo-wiki.com/HOWTO_Create_an_Updated_Ebuild, I get my first glitch when trying to use the emerge function.

    An error message appears in the console that says the function cannot be found. Any ideas on what I might do to remedy this? I've already searched my package manager for anything containing "portage" or "emerge", and I've had no luck : /

  2. #2
    Joined
    Apr 2001
    Location
    Los Angeles
    Posts
    21,104

    Re: "emerge" function missing?

    Maybe you can post a link to that Wow how to. Portage and "emerge" are things that are used in the Gentoo linux distribution, and AFAICT, not in PClinuxOS.

    Edit: From the shortest bit of googling around, it looks like WoW runs on wine in linux. What little snippets of howto that I've seen say

    1. Install wine (this would be done in Synaptic).
    2. Run the installer.

    So from a console, it would be:

    cd /mnt/cd (or whever you mount the CD).

    wine Installer.exe

    And it just goes, apparently.
    Last edited by Senor Panadero; 08-09-2007 at 07:35 PM.

  3. #3
    Joined
    Nov 2004
    Posts
    205

    Re: "emerge" function missing?

    It would appear that you are correct, sir! The How-to was for Gentoo. I'm still a linux noob, and I haven't quite grasped which programs/functions are exclusive to specific distributions.

    That being said, I have managed to install WoW and it's current expansion, so that's all good. I did have one other problem though...I tried to type (as root) # eselect opengl set ati, (as I have an ati card), and I get the error "command not found."

    I don't really know why that's not working either...

    I appreciate your help, senor!

  4. #4
    Joined
    Jul 2001
    Location
    UK
    Age
    51
    Posts
    20,229

    Re: "emerge" function missing?

    Quote Originally Posted by mdb_utphy View Post
    It would appear that you are correct, sir! The How-to was for Gentoo. I'm still a linux noob, and I haven't quite grasped which programs/functions are exclusive to specific distributions.

    That being said, I have managed to install WoW and it's current expansion, so that's all good. I did have one other problem though...I tried to type (as root) # eselect opengl set ati, (as I have an ati card), and I get the error "command not found."

    I don't really know why that's not working either...

    I appreciate your help, senor!
    portage, emerge and eselect are all gentoo-specific commands and will not be present/available on other non-gentoo based systems, hence your command not found error message.

    They all relate to the package handling system that gentoo uses. The package management system tends to be the main difference between distro's. Gentoo uses it's own protage system, Red Hat based systems use RPM, debian based systems use deb files and apt.

    I think PCLinuxOS is based off of Mandriva (Mandrake) which is RPM based, but uses synaptic/apt as it's package management system.

  5. #5
    Joined
    Jul 2001
    Location
    godfrey
    Posts
    535

    Re: "emerge" function missing?

    /me reccomends staying away from volitile/broken gentoo.
    I know exactly how the PC works. I understand the OOO, superscalar and superpiplined designs. I just don't understand how the PC doesn't work as shown in so many cases.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •