Results 1 to 8 of 8
  1. #1
    Joined
    Jul 2011
    Posts
    5

    My New build. PSU first thing to get installed for anti static. I need help with this

    Hi guys.

    Ok, just a quick view on what im doing, I have all my componants ready in box's but first I need some advice.

    I have just skrewed in my PSU (to my case) and then connected it to my mains plug and that is plugged in at the wall, the (PSU is switched off) While the plug is in the wall I can hear a high pitched whine frequency from my PSU. is this normal? or does this mean something has gone wrong? I dont want to leave it plugged in if there is danger of this causing bad effects installing the rest of my componants.

    Would really appreciate some helpfull feedback on this before I continue.

    Thanks for your time to read this.

    Clayton
    Last edited by newbuilder4000; 07-06-2011 at 08:33 AM.

  2. #2
    Joined
    Jul 2011
    Posts
    5

    Re: My New build. PSU first thing to get installed for anti static. I need help with this

    P.S it's quite a low frequency audio whine, but its coming from the PSU.

  3. #3
    Joined
    Feb 2003
    Posts
    8,739

    Re: My New build. PSU first thing to get installed for anti static. I need help with this

    what brand and model psu?

    something i've never experienced. i wouldn't consider it normal.


    ud

  4. #4
    Joined
    Jul 2011
    Posts
    5

    Re: My New build. PSU first thing to get installed for anti static. I need help with this

    its an winpower plus 750w. here is the product link: PSU

  5. #5
    Joined
    Jul 2011
    Posts
    5

    Re: My New build. PSU first thing to get installed for anti static. I need help with this

    hey, So I did a little research and installed my parts anyway. The PSU is now attached, Im sure this was a residual charge from the first currents going into the PSU. I was a little annoyed that this PSU came with its power switch already on, so obviously when I thought it was off...It was infact switched on and live, glad I didnt proceed.

    I have ran into a more common problem tho, I read something about this earlyer while trying to find some info on the whine from my power supply.

    When I switch on my p.c now, (I am not 100% sure i have the front panel switchs in the right place), but non the less I am getting a blank screen and just a loud single tone whine, loud like a siren.

    I would appreciate some help on this new problem please guys.

    I will continue to look on google of course.

    Clayton

  6. #6
    Joined
    Jan 2001
    Location
    Auckland
    Age
    40
    Posts
    30,912

    Re: My New build. PSU first thing to get installed for anti static. I need help with this

    I had a high pitch whine frequency that was noise coming from the PSU. Didn't like it. It was annoying enough to me to get it replaced with a different PSU. Different brand name. High pitch whine frequency's gone.

  7. #7
    Joined
    Feb 2003
    Posts
    8,739

    Re: My New build. PSU first thing to get installed for anti static. I need help with this

    how about filling in your system specs in the your profile or sig area.

    as to the siren, my first guess would be vid card. does it have a power connection.

    second would be memory not seated correctly.

    ud

  8. #8
    Joined
    Jul 2011
    Posts
    5

    Re: My New build. PSU first thing to get installed for anti static. I need help with this

    Well, simply the computer was letting me know there was something wrong. The sound was because my gfx card required two 6pin plugs as a source of power from my PSU. everything seams to be running now and quietly. I guess I should of stuck to common sence rather than look for the answer, thereis alot of talk about this whiney thing online, and it seams to stem from the gfx card.

    anyway guys thx.

    Clayton

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •