Results 1 to 2 of 2
  1. #1
    Joined
    Dec 2011
    Posts
    1

    I think I broke something, please help!

    Hi Everyone!

    I bought a thinkpad t410 notebook from tigerdirect and also a memory upgrade. So I was trying to install it and it wouldnt fit in the slot. Its the right memory for it (crucial pc3 10600 4gb) and number of pins are correct. It seems the memory stick is too fat for the slot.
    The slot on the motherboard is hard to work with and I was trying very hard to get it in there and ended up breaking a component off of the memory stick, but I don't care too much about that. What concerns me is that I heard a crack and maybe it came from the motherboard.

    My question is that if I broke something on the motherboard (like a component or powerline) will it show up somehow? I ran the diagnostics tool and it didnt find anything?

    And whats wrong with this slot that I cant install the memory stick?

    Thanks in advance!

  2. #2
    Joined
    Apr 2001
    Location
    New Jersey
    Posts
    7,606

    Re: I think I broke something, please help!

    Notebook memory usually installs at an angle; did you do that, or did you try and ram it in there straight on?

    If the laptop is working, then I assume everything is functioning correctly, but unless you get another stick of ram to test that slot, then I cannot say for sure. And the mobo will not test un used ram sockets, at least not that I know of.
    Rig:

    Athlon 64 X2 7750 Kuma @ 3360 Ghz @ 1.475V (14.5x223)
    (NB: 2240, HT: 2015)
    Gigabyte MA-790X-UD4P
    Sparkle GeForce 9800 GTX+ (755core, 1350 mem)
    Onboard sound (yuck)
    4GBs Mushkin DDR800 (6/6/6/18/24 @ 928mhz)
    2x74GBs RAID 0
    2xWD 1TB HD RAID 1
    Plexter DVD Burner
    Rosewill 530W

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •