Results 1 to 7 of 7
  1. #1
    Joined
    Jul 2005
    Location
    columbia, mo
    Age
    26
    Posts
    860

    Windows 7 Sharing Everyone Full Control not applying all folder?!?

    So I set the security for the everyone user to full control and tell it to change it for all files and folders within the driver. I'm setting full control for everyone so i can move files and folders etc over my network.

    It simply doesn't apply the "Everyone" user to full control on all the folders.

    How do I make it set the "full control" for the "Everyone" user for ALL files and folders within the drive? Like a full batch security change to full control?

    THANKS
    -Intel Core i7 930 @ 4.533Ghz Max (Lapped) ***~51,941 CPU QUEEN~***
    -Cocage True Spirit (Lapped)
    -6GB OCZ DDR3-1600 @ DDR3-1600
    -ASUS RAMPAGE II GENE
    -ASUS & ZOTAC GeForce GTX 470s SLI @ 851Mhz Core, 1702Mhz Shader, 1875Mhz Memory @ 1.1625v ---- Stats are 68 Billion Pixels per second, 90.8 Billion Texels per second, and 300,000 Mega Bytes per second memory bandwidth with 640bit GDDR5.
    -2TB_RAID0 Black Edition, 500GB_RAID0, 2TB Green Edition, 1TB Baracuda Drive
    -Lian Li PC-V354 Case - **Custom Modding In Progress**
    -Kingwin MK-1000W Black Premium Edition Power Supply
    -PIONEER VSX-520-K HOME THEATER 3D HIGH DEFINITION RECEIVER
    -Dayton Audio Dayton HTP-3 5.1 Home Theater Package 12" Powered Subwoofer
    -Samsung LN40B500 40" 1080p LCD HDTV

  2. #2
    Joined
    Dec 2000
    Posts
    5,051

    Re: Windows 7 Sharing Everyone Full Control not applying all folder?!?

    Sounds like your setting the file system permissions rather then the sharing permissions.

  3. #3
    Joined
    Jul 2005
    Location
    columbia, mo
    Age
    26
    Posts
    860

    Re: Windows 7 Sharing Everyone Full Control not applying all folder?!?

    It's like when I go to "Computer" and right click on d drive to properties. Then moving to security. I add Everyone to the allowed users and add full control. However it's supposed to set it to all files and folders but it simply doesn't apply the correct permissions to all files and folders. This is on Win 7 x64 ultimate.
    Last edited by chris89; 04-09-2012 at 03:11 AM.
    -Intel Core i7 930 @ 4.533Ghz Max (Lapped) ***~51,941 CPU QUEEN~***
    -Cocage True Spirit (Lapped)
    -6GB OCZ DDR3-1600 @ DDR3-1600
    -ASUS RAMPAGE II GENE
    -ASUS & ZOTAC GeForce GTX 470s SLI @ 851Mhz Core, 1702Mhz Shader, 1875Mhz Memory @ 1.1625v ---- Stats are 68 Billion Pixels per second, 90.8 Billion Texels per second, and 300,000 Mega Bytes per second memory bandwidth with 640bit GDDR5.
    -2TB_RAID0 Black Edition, 500GB_RAID0, 2TB Green Edition, 1TB Baracuda Drive
    -Lian Li PC-V354 Case - **Custom Modding In Progress**
    -Kingwin MK-1000W Black Premium Edition Power Supply
    -PIONEER VSX-520-K HOME THEATER 3D HIGH DEFINITION RECEIVER
    -Dayton Audio Dayton HTP-3 5.1 Home Theater Package 12" Powered Subwoofer
    -Samsung LN40B500 40" 1080p LCD HDTV

  4. #4
    Joined
    Dec 2000
    Posts
    5,051

    Re: Windows 7 Sharing Everyone Full Control not applying all folder?!?

    That actually only sets the permission on the object you have added everyone to, there is an advanced option to set the permissions on all child objects.

    However, this has no effect on sharing files between computers as that is filesystem permissions.

    You'd need to use the sharing tab for that.

  5. #5
    Joined
    Jul 2005
    Location
    columbia, mo
    Age
    26
    Posts
    860

    Re: Windows 7 Sharing Everyone Full Control not applying all folder?!?

    I have my advanced sharing setup for my entire hard drive. I don't want to share individual folders etc. I have that machine setup as my sever since I has a couple raid 0 arrays and tons of tera bytes of room and hella performance. I'm accessing over gigabit and it works great like I'm directly connected however I have hit the gigabit bottleneck at what 150-200MB/s? When the RAID can a do a little more but that's some damn good transfer speeds right?

    Anyway, I access the machine over the workgroup and I see the D, and E drive and most of the directories have full permissions but some don't. That's my problem. How do I make sure that the permissions are 100% going to be applied to all parent and child directories? I'm setting the Everyone to "Full control". I'm not concerned about security threats.

    Thanks
    -Intel Core i7 930 @ 4.533Ghz Max (Lapped) ***~51,941 CPU QUEEN~***
    -Cocage True Spirit (Lapped)
    -6GB OCZ DDR3-1600 @ DDR3-1600
    -ASUS RAMPAGE II GENE
    -ASUS & ZOTAC GeForce GTX 470s SLI @ 851Mhz Core, 1702Mhz Shader, 1875Mhz Memory @ 1.1625v ---- Stats are 68 Billion Pixels per second, 90.8 Billion Texels per second, and 300,000 Mega Bytes per second memory bandwidth with 640bit GDDR5.
    -2TB_RAID0 Black Edition, 500GB_RAID0, 2TB Green Edition, 1TB Baracuda Drive
    -Lian Li PC-V354 Case - **Custom Modding In Progress**
    -Kingwin MK-1000W Black Premium Edition Power Supply
    -PIONEER VSX-520-K HOME THEATER 3D HIGH DEFINITION RECEIVER
    -Dayton Audio Dayton HTP-3 5.1 Home Theater Package 12" Powered Subwoofer
    -Samsung LN40B500 40" 1080p LCD HDTV

  6. #6
    Joined
    Dec 2000
    Posts
    5,051

    Re: Windows 7 Sharing Everyone Full Control not applying all folder?!?

    Now that part ironically is handled by the filesystem permissions.

    You need to go into security, advanced, change permissions, everyone, edit, full control and then ok.

  7. #7
    Joined
    Jul 2005
    Location
    columbia, mo
    Age
    26
    Posts
    860

    Re: Windows 7 Sharing Everyone Full Control not applying all folder?!?

    Yep did it. It only applied to some directories. Why wouldn't it apply to all? I un-applied then re-applied and re-did like 20 times. Why doesn't it work automatically? Anyway to set the command for all parent child directories via command prompt or something?
    -Intel Core i7 930 @ 4.533Ghz Max (Lapped) ***~51,941 CPU QUEEN~***
    -Cocage True Spirit (Lapped)
    -6GB OCZ DDR3-1600 @ DDR3-1600
    -ASUS RAMPAGE II GENE
    -ASUS & ZOTAC GeForce GTX 470s SLI @ 851Mhz Core, 1702Mhz Shader, 1875Mhz Memory @ 1.1625v ---- Stats are 68 Billion Pixels per second, 90.8 Billion Texels per second, and 300,000 Mega Bytes per second memory bandwidth with 640bit GDDR5.
    -2TB_RAID0 Black Edition, 500GB_RAID0, 2TB Green Edition, 1TB Baracuda Drive
    -Lian Li PC-V354 Case - **Custom Modding In Progress**
    -Kingwin MK-1000W Black Premium Edition Power Supply
    -PIONEER VSX-520-K HOME THEATER 3D HIGH DEFINITION RECEIVER
    -Dayton Audio Dayton HTP-3 5.1 Home Theater Package 12" Powered Subwoofer
    -Samsung LN40B500 40" 1080p LCD HDTV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •