Results 1 to 2 of 2
  1. #1
    Joined
    Dec 2012
    Posts
    1

    Gigabyte Motherboard Initial USB Port Issues

    I just purchased a Gigabyte Motherboard from Newegg to install in my new computer (all of the parts installed were brand new). After hooking everything up, I turned the computer on, and the Bios screen turned on for a sec, then went to black. The computer made no response when I started pushing keys on the keyboard. I turned off the computer, turned off the PSU, then switched the USB keyboard into each of the USB drives on the computer, then turned the PSU and computer on and tried again, but to no avail. It didn't seem like it would recognize the keyboard, because none of the "lock" lights were on, and would not turn on when pressing Caps Lock, Num Lock, etc. I then brought home about 4 ps2 keyboards to hook up to the ps2 port. I plugged in each keyboard to the computer using the same details as before, but the computer still did not do anything. The Num Lock light was on, but would not turn off when pressing the Num Lock button. Caps Lock and Scroll Lock buttons did not turn on their respective lights.

    Is this something that can be fixed, or should I return it to Newegg?

  2. #2
    Joined
    Feb 2003
    Posts
    8,684

    Re: Gigabyte Motherboard Initial USB Port Issues

    the pc should post to video even if there is a keyboard issue.

    i would set the board up outside the case on a non-conductive surface and see how it posts. you don't need any of the drives for now.

    list your parts in your sig.

    ud

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •