Results 1 to 3 of 3
  1. #1
    Joined
    Dec 2012
    Posts
    1

    Klipsch Promedia 2.1 Speakers/ Distorted sound from both speakers

    Hello Everyone,

    I previously owned three computer speakers which after volume them up they blown. (I owned two Logitech z2300, one Mtx Lp1200 & now the Klipsch 2.1 ) My current speaker is the Klipsch which after thanksgiving family dinner blown. As a result of high volume and prolonged used. All the speakers I previously owned have had the same exact problem and I really don't know what to do to fix this. I was told that my current speaker (which is the one that I would like to repair) have the fuse blown. Please note that the bass work perfectly fine and when I connect the headphones too. Thank you for your time and any help will be appreciated.

  2. #2
    Joined
    Dec 2000
    Location
    Cape Cod, MA
    Age
    57
    Posts
    11,619

    Re: Klipsch Promedia 2.1 Speakers/ Distorted sound from both speakers

    If the speakers are working, but distorted, it is not a fuse. You have simply blown the speaker. It sounds like you just want much more volume than those little speakers can put out. I suggest you get a pair of non-powered bookshelf speakers, and a small amp to power them. You will be able to go much louder and cleaner than with "computer speakers". I personally use a pair of Dayton B652's, which can be had for less than $50 and far outperform their price point. Get a small T-amp for under $50 and you are all set. Or use an old Stereo receiver.

  3. #3
    sttubs is offline Always learning something
    Joined
    Feb 2004
    Location
    Rock Falls, IL
    Age
    48
    Posts
    946

    Re: Klipsch Promedia 2.1 Speakers/ Distorted sound from both speakers

    It's odd that you've blown 3 sets of speakers with the same computer. I've not heard of a sound card causing that before. If you like the music real loud then go with John's suggestion.
    AMD 8350 w/Xigmatek Dark Knight Night Hawk Ed - Asus M5A99FX PRO R2.0 w/4x4gb GSkill Ripjaws 1600 CL7 - WD Black WD2003FZEX 2TB - EVGA GTX 780 Ti SuperClocked - Win 7 Premium 64bit - Lite-On iHES108 - White Corsair 500r w/Corsair AX860i 860W - HP XP599AA

    Heat: http://www.heatware.com/eval.php?id=55337
    Ebay: http://myworld.ebay.com/sttubs/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •