Results 1 to 1 of 1
  1. #1
    Jun 2001
    N. New Joisey

    ASRock 960GM/U3S3 Update BIOS problem

    Just installed in HTPC update, nice little low cost MB; one of few Micro ATX to accept AMD and provide SATA III + USB3.

    Its all working nicely except call me strange, I want to install the latest 1.40 BIOS (it came with 1.30) that's where my problem starts.

    When I boot to update BIOS screen it reports no updated bios found. Its meant to be able to scan and find the new BIOS from HD, CD or USB memory stick. Not in my case. F3 rescan results in jumping back to the "not found" screen, there is no option to tell it where to look.

    Having some previous experience, I figured anything connected to my front USB 3.0 connector will not have loaded drivers at this point, so I tried the USB stick (FAT32) and both a USB DVD reader and floppy disk in the USB 2.0 rear panel connector - again nothing.

    I tried placing the file (960USFX1.40) in the root of the HD, on a CD (SATA), etc, but still no luck

    Any ideas how to dictate where the BIOS updater has to look for the new version?
    Last edited by Britgeezer; 11-22-2013 at 05:29 PM.
    the Britgeezer

    My Heat otherwise a smoke free home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts