Results 1 to 10 of 10
  1. #1
    Joined
    Jul 2014
    Posts
    16

    ATI 5850 screen going blank revisited

    Not going to believe this !
    Was using a cheap wireless KB for the last several months and during gaming my character would not move forward or back at times like the W and S keys were to blame.
    I thought it was Steam because it would happen after some time online. My card would also do the usual screen going blank after gaming for a while.
    So I get out my trusty Microsoft KB that isn't USB uses the old style KB port.
    Now the crazy part...no freezing anymore of my character in L4D2 and there have been NO video crashes so far.
    How is this possible ?
    Ahhhhhh ! Video just crashed...screen changing colors , then BSOD. KB not related I guess.
    Last edited by bufbarnaby; 07-31-2014 at 07:59 PM.

  2. #2
    Joined
    Jun 2003
    Posts
    2,092

    Re: ATI 5850 screen going blank revisited

    What are the rest of your specs?

  3. #3
    Joined
    Jul 2014
    Posts
    16

    Re: ATI 5850 screen going blank revisited

    Well...finally started crashing a lot...Windows said Display driver stopped working.
    I vacuum out my case every month or so but this time I blew out the video card and a LOT of dirt came out...video working so far : )
    Could this be the problem ???
    Last edited by bufbarnaby; 08-03-2014 at 09:54 PM.

  4. #4
    Joined
    Jul 2014
    Posts
    16

    Re: ATI 5850 screen going blank revisited

    Asus P5Q SE 8 GB DDR2 Patriot memory 1TB Caviar Black 500W Antec PSU (expensive one not junk) ATI Radeon 5850 1GB by Diamond Yorkfield C2Q with 12 MB L2 Cache @2.83 GHZ Nothing overclocked.

  5. #5
    Joined
    Jul 2014
    Posts
    16

    Re: ATI 5850 screen going blank revisited

    Gaming all settings maxed for 4 hours...no problemo !

  6. #6
    Joined
    Jul 2014
    Posts
    16

    Re: ATI 5850 screen going blank revisited

    Can anyone please explain how blowing dust out of card made it not crash anymore ?
    Temps were never high per Catalyst Control Center. It wasn't like dust bunnies were popping out of the card either.
    Can dust cause a short somehow ?
    It's been rock solid for 3 days of heavy use.

  7. #7
    Joined
    Jul 2014
    Posts
    16

    Re: ATI 5850 screen going blank revisited

    Still rock solid ! No more blaming drivers/hardware Like AMD again ; )

  8. #8
    Joined
    Aug 2000
    Location
    Vvardenfell
    Age
    58
    Posts
    10,925

    Re: ATI 5850 screen going blank revisited

    In answer to your question in the previous post: cooling. If you get a lot of dust in the fan it will reduce the ability of the cooler to remove heat. It might even get in the fan bearings and slow the fan down, making things worse. The rest of the symptoms you had are fairly typical of overheating.

  9. #9
    Joined
    Jul 2014
    Posts
    16

    Re: ATI 5850 screen going blank revisited

    Thanks...Every other person was saying it was hardware failure.
    I have two big 3-speed dual ball bearing case fans on the lowest setting....maybe time to crank up the speed on those too.
    Added a third fan to the top right above where the video card sits. Feel warm air being sucked out.
    Last edited by bufbarnaby; 08-09-2014 at 04:56 PM.

  10. #10
    Joined
    Jul 2014
    Posts
    16

    Re: ATI 5850 screen going blank revisited

    Case closed !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •