Results 1 to 3 of 3
  1. #1
    Jan 2015

    How to install Unreal Tournament 2004 in Linux in 2015

    Preparing for pcper VLAN #9

    By the time I built my current gaming system, sometime in 2010, I wasn't really playing UT2004 anymore. So, I have never installed UT2004 on my current machine. I know, how could I, right?

    So, when I heard about a pcper VLAN that I will actually be able to attend, I scoured the internet to see what it will take to get the game up and running on my machine again.

    So, here's how to do it.

    I'm using openSUSE 13.2 but I'm pretty sure you will be able to follow very similar instructions on most current distros. I am also relying on an original DVD that includes the linux installer. I've heard that some discs don't include an installer, if this is your situation you'll have to do some additional googling to get it installed because I've also heard that the installers don't work anymore. That's outside the scope of these instructions.

    The basic information I found on this Ubuntu community wiki page. However, not everything there was completely accurate.

    First, I dug up my UT2004 DVD Special Edition disc. Mount the disc and view the contents. Copy the file “” to your local hard drive and change the permissions to make it executable, it won't run directly from the DVD. Then open a terminal, change to the directory where you've saved the installer script, and run the script. In my example here I've created the folders ~/games/UT2004 to house the files:
    pico@weasel:~> cd games/UT2004/
    pico@weasel:~/games/UT2004> ./
    While installing the script asked me a number of questions, most of which I said “no” to. You may make a different choice, but I don't need to view the readme file, I don't need library source code, I don't want symobolic links to a folder in my path, and I don't want it to try and add the game to my menus.

    Also, it will give an option to specify the location of the install, the default being /usr/local/games. In a default openSUSE install I do not recommend using that location. By default openSUSE creates a root partition that is only 40GB maximum size (prior to 13.2 it was only 20GB) and puts the rest of your disk into a different partition mounted at /home. I don't want to fill up that 40GB partition with games, so I recommend changing the installation to somewhere in your /home directory. I'm installing into /home/username/games/UT2004

    Now, the reason I don't install menu entries and whatnot is because I don't expect it to work on the first try. Starting the game from the command line will give me clues as to why it doesn't work. So, once it was installed I tried to run the game by running the ut2004 script in the installaton directory, and got the following error:
    pico@weasel:~/games/UT2004> ./ut2004 
    ./ut2004-bin: error while loading shared libraries: cannot open shared object file: No such file or directory
    So, back to the Ubuntu community wiki page, there's a paragraph about this problem. Turns out libstdc++5 was superseded by libstdc++6 about the same time this game was released. If you're using Ubuntu it looks like you're in luck, you should be able to find the old version in the repos. For openSUSE I had to head back to Google. I found somebody that had a similar problem a couple of years ago with Suse Enterprise Server 11, and there was a link to a reputable looking repo from a reputable looking person (you may not agree). I poked around said repo and found the same package for openSUSE 13.2 is available here:

    Now I was able to run the game, but it ran terrible. Really slow and laggy and there was no sound. Hoping the latest patch would fix this, I found the easiest way to get this is to install the Mega Pack. The Mega Pack contains the ECE Bonus Pack, UT2004 patch 3369.2 and some Assault, Capture the Flag and Deathmatch maps.

    So, go to the Loki Installers for Linux Gamers website:
    and download the file “”. Save it somewhere handy, change permissions to make it executable, and run it in a terminal:
    pico@weasel:~/games/UT2004> ./
    It pops up a graphical installer. I left the defaults (which goes directly against what I said I wanted earlier) and clicked install.

    That brings us up-to-date with the latest patch and installs the content mentioned above. The game ran correctly now, but there was still no sound.

    Going back to the Ubuntu community wiki page I found a solution for Ubuntu users near the end of the page. When I look at the output in the terminal after quitting the game I can see it throws an error:
    open /dev/[sound/]dsp: No such file or directory
    It is not exactly the error shown in the Ubuntu web page, but close enough. Looks like in Ubuntu you can run a program called “padsp” that will grab the output from a program trying to run old school OSS sound and pipe it into Pulse Audio. I didn't see such a program in the openSUSE repos, even through openSUSE does use Pulse Audio. But, as with all these distros, it runs Pulse Audio on top of ALSA, and I found a program call “aoss” in openSUSE that does the same thing, grabs output and pipes it into ALSA (I honestly still don't know why they all run Pulse Audio now). I think I had to install this, it wasn't already installed. So, when I want to play the game I use the following command:
    pico@weasel:~/games/UT2004> aoss ./ut2004
    and voila, I have sound.
    There are still more maps we want. We want the Community Bonus Packs and the Ultimate Community Map Packs. At this point you have seen that there are installers for these on the website, but those installers don't work anymore. When you run them you get an error saying the program can't find some ancient version of gtk+ which it needs to draw that graphical installer. So we need to go and get them as zip files, available here:

    download,,, and,

    Put these files into the directory where you've installed the game, in my case this is the ~/games/UT2004 directory. The correct folder structure already exists inside the zip files, so you just extract the zip into the current directory and all of the necessary files go into the right sub-folders.

    And finally, as far as maps are concerned, the VLAN #9 forum thread has a link in the second post to the Fragball Stadium map. Download the zip file and extract it just like the previous zip files.

    At this point I think we're good to go. If anyone finds some faults or knows of something I missed, let me know and I'll add it in.

    - BadSquishy
    Last edited by BadSquishy; 03-05-2016 at 02:13 AM.

  2. #2
    Jun 2001
    Southern Tier of NY

    Re: How to install Unreal Tournament 2004 in Linux in 2015

    Thanks for posting that. Maybe it will get us a few more UT2004 players for the VLAN
    If you enjoy gaming click here to learn about the Fragging Frogs.

    [Proudly using only AMD desktop CPUs since 1996 and now also GPUs in 2014 - Thanks AMD!!]
    My Rigs - My Upgrade History - My Games

  3. #3
    Jan 2015

    How to install Unreal Tournament 2004 in Linux in 2016

    So, as I mentioned in the post for the upcoming VLAN I'm installing UT2004 in Linux for the umpteenth time.

    This time I'm on openSUSE Leap 42.1 which turns out to be much more buggy than openSUSE 13.2 was.

    Anyways, here are a couple of updated links and other info I needed to get it working.

    Instead of using the original link for libstdc++5 I used one from the same repo, but in the section for Leap 42.1 instead of the older 13.2. Here's the link:

    Next I found that the direct download from liflg.or for the MegaPack was broken. So I tried the torrent link and found that if you are patient it will eventually download the file.

    I didn't check the rest of the downloads, it turns out I still had the files from last year.

    And the aoss thing, I found that it was already installed in openSUSE Leap 42.1 so I didn't have to uninstall it.

    I do find this to work well much of the time, but it is a little buggy. Mainly, it can sometimes run really slow and laggy when you try and start the game for the second or third time. I can usually fix this by logging out of the machine (to make sure all memory and processes are freed up) and log back in, then start the game without doing too much else in between.

    Hope this helps people.

    - BadSquishy
    Last edited by BadSquishy; 03-05-2016 at 02:44 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts