Results 1 to 2 of 2
  1. #1
    Feb 2017

    Crossfire with rx 470 nitro 8gb but not working

    Hey guy´s i have a problem so i already read it on the forums but i think i have a different problem the thing is i want to crossfire my sapphire 470 nitro 8gb but it doesn´t work.

    this link shows a german forum where i post my specs etc there are at the start.

    i have 2 identical gpu´s
    i5 6500k
    16gb ram
    650w power supply
    z170a gaming m3 mainboard

    when i look at the crimson radeon settings 1 card is listed as primary and they showing the activity the second one showing as deactivated and no activity when i put a screen on the second one then the card activate.
    i have no option to toogle the crossfire option on i already deinstalled the driver´s with ddu still no option the powersupply is correctly on

    i saw that some people have their cards shown in one rider in crimson but my looks different

    i have no idea how to activate the second card or toogle the crossfire option on

    sorry about my english
    ask me if i forgett something

    And please help me!!!!

  2. #2
    Jun 2012

    Re: Crossfire with rx 470 nitro 8gb but not working

    Hi, PoorAMDUser. Below is a link to a thread that seems to be similar to your situation. The best answer is highlighted in green:

    There are actually two suggestions in the thread. The best answer recommends you reinstall the OS. I'm guessing you have Win10 which allows you to save your data and reset the PC (Settings--Update & Security--Recovery--Reset this PC). It's nice but you will lose most apps you've installed.

    I would try the other suggestion first:
    • Uninstall all AMD driver software
    • Shut down the computer and install 1 GPU
    • Turn on the PC and see if the GPU is recognized by the OS (right click Start Button--Device Manager--Display Adapters). Hopefully there is no Yellow Exclamation Point by the GPU
    • If this is successful, shut down and install the second GPU
    • Turn on the PC and see if both GPUs are recognized without the exclamation point
    • If everything has worked up to here, now install the AMD Crimson application (be sure to download the latest version before you start this whole process)
    • I believe Crossfire is in Global Settings (Open Crimson--Gaming--Global Settings)

    If you get the Yellow Exclamation point after you install the first GPU, install the drivers at that point as opposed to waiting until the end.

    Let us know what happens.

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts