Results 1 to 4 of 4
  1. #1
    Joined
    Jun 2001
    Location
    Indpls. IN.
    Posts
    7,895

    auto mount internal HHD

    well I just made the switch , windows 10 drove me up the wall !! So I went running to linux , tryed many distros but antergos won out . BUT being a noob to linux I got a issue , I am using a 500 gb 850 samsung evo that I managed to reformat to ex4 I want to use as storage , I can see the drive in linux just fine but every time I want to access it I got to enter a password then I can use it Grrrr ! :anguished: how do I stop this and just have the drive auto mount . I have looked at 10 youtube vids nothing is working , seems I do not have root access or I cant get it to wok acording to the vids ( note these were for linux mint ) is it different for this version ?

    And on another note I cant get my canon ip1800 to work tryed installing all the PPD files form the updater but no joy , tryed using different drivers but I have no option for my exact model / Linux sees the printer just fine , sees it as a usb printer just cant print anything !
    "The Lord Is My Shepherd, I Shall Not Want"
    PS:23

  2. #2
    Joined
    Jun 2001
    Location
    Indpls. IN.
    Posts
    7,895

    Re: auto mount internal HHD

    nevermind looks like I just have to get a new printer becasue I cant get my old one to function under linux
    "The Lord Is My Shepherd, I Shall Not Want"
    PS:23

  3. #3
    Joined
    Dec 2001
    Location
    Phelan,Calif.
    Posts
    84

    Re: auto mount internal HHD

    I heard here that Cannon is does not make much effort on Linux drivers.

    HP printers are much more Linux friendly.
    If you can't explain it simply, you don't understand it well enough.
    -Albert Einstein

  4. #4
    Joined
    May 2002
    Location
    Kansas
    Age
    32
    Posts
    1,088

    Re: auto mount internal HHD

    I don't know if you're still looking for a solution to this, but I just came across your thread. In linux, your /etc/fstab config file determines which drives are auto-mounted. You're asked for a password each time currently because it isn't mounted at startup and the location the disk is mounting to (usually /media or /media/yourusername) isn't configured to allow your user account to modify its contents such as by mounting a volume to it. This is a good thing.

    The solution is to do one of two things, both of which require a small edit to your fstab.

    Either option will require you to identify the volume you wish to mount. Note that the commands shown here both require super user privilege, so you will have to issue them with sudo or as su. You can identify your volume using fdisk -l to find the device name (such as /dev/sdb) and then look at its partitions to see which one you're interested in (such as /dev/sdb1). Once you've determined that, take a look at the output from blkid to get that volume's unique identifier (the UUID=xxxx part of each line). You can ignore other UUIDs like PARTUUID or UUID_SUB if present. You can set up a mount line without the UUID by using the partition's device path if you want to, but if your system's disk arrangement ever changes your fstab will no longer work correctly. Using a UUID is the modern way and is definitely recommended.

    Okay, open your /etc/fstab in nano or pluma or whatever text editor you like. You'll have to do this with super user privilege to be able to save your changes.

    Option 1) Auto-mount the disk at startup.

    UUID=xxxx /media/yourusername/mountname filesystemtype defaults 0 0

    If your UUID were f4bbfd8d-6969-4102-b8fd-2218846573f6, it is an ext4 volume, your username is "brother", and you want to mount it as "backups" you'd do this as an example:

    UUID=f4bbfd8d-6969-4102-b8fd-2218846573f6 /media/brother/backups ext4 defaults 0 0

    Option 2) Mount on demand but allow your user permission to trigger it (ie without having to provide your password).

    The same as above but with a couple different options:

    UUID=f4bbfd8d-6969-4102-b8fd-2218846573f6 /media/brother/backups ext4 defaults,noauto,user 0 0

    The noauto option tells your system not to automatically mount the volume at startup or when mount -a is called (ie mount "all"). The user option tells your system to allow regular users to mount the volume. This doesn't change the required permissions to actually execute the mount in the background, but the system will execute the mount as root on your behalf even when you're just a regular user.
    Last edited by TBird761; 02-01-2018 at 10:13 AM.
    Sometimes I feel like I'm becoming a dinosaur.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •